view debian/changelog @ 1430:cfc7af97c295

Added dw_window_set_preferred_size() prototype to the header.
author bsmith@81767d24-ef19-dc11-ae90-00e081727c95
date Sun, 04 Dec 2011 20:18:50 +0000
parents edad104e7714
children f0a4731bc40e
line wrap: on
line source

dwindows (2.2-1) unstable; urgency=low

  * Added printing support via dw_print_new, dw_print_run and dw_print_cancel.
  * Added pixmap font override support. In prior versions when drawing
    text to pixmaps the font set on the associated window handle is used.
    dw_pixmap_set_font() can now override that font setting, and now
    pixmaps without associated windows are supported and used in printing.
  * Added dw_pixmap_stretch_bitblt() which allows for scaling during bitblt.
    This function is necessary largely for very hi-res printer contexts.   
  * Added dw_mutex_trylock() function to try to obtain a mutex without blocking.
  * Added DW_TIMEOUT_INFINITE which can now be used with dw_event_wait() in 
    addition to dw_named_event_wait(), to block until the event is posted.
  * Added DW_PERCENT_INDETERMINATE which can be passed to dw_percent_set_pos().
    This should work on all platforms except old versions of Windows. 
  * Added the subversion revision number as the third Dynamic Windows version 
    number when building from a subversion source tree.
  * Added dw_container_set_row_data() and dw_container_change_row_data() macros
    which just call dw_container_set/change_row_title() but with (void *).
  * Added dw_container_set_stripe() to set alternating row colors.
    Currently Mac, Win and GTK are supported.
  * Added taskbar support on the Mac, GTK (Gnome) and OS/2 (e/XCenter+Systray).
  * Added PNG/JPG/GIF/TIFF support on Windows via GDI+.
  * Added support for GdkPixbuf inline images in GTK 2 and 3.
  * Added dw_draw_arc() function for drawing arcs, ellipses and circles.
  * Added DW_DRAW_DEFAULT, DW_DRAW_FILL and DW_DRAW_FULL flags which can be passed
    to dw_draw_arc(), dw_draw_rect() and dw_draw_polygon().  The fill parameter
    in the latter two has been replaced with flags where DW_DRAW_FILL is the
    same as TRUE so code using the old scheme should still work unchanged.
  * Added DW_MENU_AUTO and DW_MENU_POPUP constants for autogenerating menu IDs.
  * Added dw_debug() function for sending debug messages to the console.
  * Added path and/or filename support to dw_file_browse() on OS/2, Windows,
    GTK2, GTK3 and Mac 10.6 or higher.
  * Added custom calendar widget for OS/2, leaving only the HTML widget missing.
  * Improved container optimization on Mac, header width now taken into account.
  * Fixes for incorrect return codes from the dw_event_* functions on Windows.
  * Fixes for incorrect behavior on key_press callbacks on Mac and Windows.
  * Fixes for MDI support in GTK3. 
  * Fixes for problems with multiple sliders/percent widgets in a box on OS/2.
  * Fixes for lots of GTK3 layout and window positioning issues... 
    although minimum size issues are still present.

 -- Brian Smith <brian@dbsoft.org>  Sun, 20 Nov 2011 08:00:00 +1000

dwindows (2.1-1) unstable; urgency=low

  * Added support for MacOS 10.7 Lion, version 2.0 had some issues.
  * Changed the font point size on Windows to be system consistent.
    Applications setting Windows fonts may need to be adjusted
    after upgrading to version 2.1. This eliminates an old
    workaround, but causes old fonts to potentially be wrong.
  * Fixed issues with the tree widget on Mac not being able to add
    nodes at the same level with the same name.
  * Added dw_font_set_default() to set the default text widget font.
  * Added dw_font_choose() to display a dialog to pick a font.
  * Added dw_box_pack_at_index() like the other dw_box_pack_*() 
    functions except packing at arbitrary locations is possible.
  * Added DW_INT_TO_POINTER/DW_POINTER_TO_INT/etc macros.
  * Fixed gcc warnings on 64bit systems and others.
  * Fixes for loading images from files on Windows and GTK3.

 -- Brian Smith <brian@dbsoft.org>  Sat, 30 Jul 2011 08:00:00 +1000

dwindows (2.0-1) unstable; urgency=low

  * Added support for MacOS 10.5 and higher Intel and PPC via Cocoa.
  * Added initial (unstable) support for GTK version 3.
  * Added support for Windows themes on XP and higher.
  * Added scrollbox widgets, which function like boxes but...
    scrollbars allow you to pack more into them than the visible area.
  * Added dw_window_get_font() for checking the font used on a widget.
  * Added dw_container_change_row_title() for changing a row pointer after insert.
  * Added clipboard support on OS/2.
  * Added HICN data type for icon handles an changed icon functions to use it.
  * Added DW_RESOURCE() macro for casting to HICN when using resource IDs.
  * Added support for borderless buttons except on Windows (DW_BS_NOBORDER).
  * Changed the return codes of dw_container_setup, dw_filesystem_setup and
    dw_event_wait().  Please check any code that use these functions.
  * Changed GTK2+ now supports font name styles like the other platforms.
  * Enhanced transparent bitblt on OS/2 and Windows.  OS/2 now supports
    transparent color and Windows now supports 32bit alpha bitblt.
  * Removed thread limits on Windows and GTK using thread local storage.

 -- Mark Hessling <mark@rexx.org>  Wed, 1 Jun 2011 08:00:00 +1000

dwindows (1.1-1) unstable; urgency=low

  * Initial debian release

 -- Mark Hessling <mark@rexx.org>  Sun, 12 Apr 2009 13:18:35 +1000