view debian/control @ 909:c092eab43ae3

Experimental change to pixmap rendering. Switch from using NSImage to NSBitmapImageRef to store the image. This is closer to the core backing store used to display images. Using this I was able to avoid using lockFocus on the images and instead set the graphics context manually allowing us to draw directly on the backing image. However NSBitmapImageRef is a more simple format and didn't work with the flipped Y axis... so... I had to perform some voodoo to get the flipping to work with the graphics context. Not sure it is 100% right.
author bsmith@81767d24-ef19-dc11-ae90-00e081727c95
date Wed, 20 Apr 2011 14:09:00 +0000
parents 9ab89d89e6b4
children 6ad811834512
line wrap: on
line source

Source: dwindows
Section: devel
Priority: optional
Maintainer: Mark Hessling <mark@rexx.org>
Build-Depends: debhelper (>= 5), autotools-dev
Standards-Version: 3.7.2

Package: dwindows
Architecture: any
Depends: ${shlibs:Depends}
Description: Dynamic Windows is a lightweight GUI API for C.
 dwindows provides a high-level wrapper over GTK+ to provide
 a simple, lightweight GUI hiding some of the complexity of GTK+.
 It provides the same API for GTK+, native Windows and OS/2.