view debian/control @ 2819:a2fc275fa9bb

iOS: Fix major memory leaks when destroying widgets and windows. More surely needs to be done regardig this, iOS doesn't destroy subviews as expected when the parent is removed. I was expecting it to bring the reference counts to 0 and starts destroying subviews... so I had to do this manually. Boxes, ScrollBoxes, Spinbuttons and Comboboxes all now destroy their subviews. Probably will need to do the same for splitbar, notebooks and possibly others. However this stops the memory leak in Interface Builder when recreating the interface. Also need to figure out why the reference count is lower for DWButtons.
author bsmith@81767d24-ef19-dc11-ae90-00e081727c95
date Tue, 02 Aug 2022 06:17:09 +0000
parents 6ad811834512
children
line wrap: on
line source

Source: dwindows
Section: devel
Priority: optional
Maintainer: Mark Hessling <mark@rexx.org>
Build-Depends: debhelper (>= 5), autotools-dev
Standards-Version: 3.7.2

Package: dwindows
Architecture: any
Depends: ${shlibs:Depends}
Description: Dynamic Windows is a lightweight GUI API for C.
 dwindows provides a high-level wrapper over GTK+ to provide
 a simple, lightweight GUI hiding some of the complexity of GTK+.
 It provides the same API for GTK+, native Windows, MacOS X and OS/2.