diff configure.ac @ 2978:d84182f0054e

GTK4: Support for dw_html_javascript_add() and DW_SIGNAL_HTML_MESSAGE. Also add support for the stable WebKitGTK 6.0 for GTK4. They changed a lot including the package name, add USE_WEBKIT6 for this.
author bsmith@81767d24-ef19-dc11-ae90-00e081727c95
date Fri, 24 Mar 2023 23:04:39 +0000
parents 83c17a84bc27
children a464a74505f7
line wrap: on
line diff
--- a/configure.ac	Fri Mar 24 17:35:53 2023 +0000
+++ b/configure.ac	Fri Mar 24 23:04:39 2023 +0000
@@ -231,8 +231,9 @@
          fi
          if test x"$GTK_LIBS" != x; then 
             DW_DIR=gtk4
-            # WebKit2GTK built for GTK4 becomes 5.0
-            WEBKIT_PKG="webkit2gtk-5.0"
+            # WebKit2GTK built for GTK4 becomes 5.0 or 6.0
+            WEBKIT_PKG="webkitgtk-6.0"
+            WEBKIT_ALT_PKG="webkit2gtk-5.0"
          fi
       else
          # Put the GTK2 test here since --with-gtk2 is mutually
@@ -282,6 +283,9 @@
          if test "$WEBKIT_PKG" = "webkit2gtk-4.0"; then
             AC_DEFINE(USE_WEBKIT2,1,Uses WebKit 2)
          fi
+         if test "$WEBKIT_PKG" = "webkitgtk-6.0"; then
+            AC_DEFINE(USE_WEBKIT6,1,Uses WebKit 6)
+         fi
       fi
       if test x"$RPATH" != x; then
          RPATH="-Wl,-R$RPATH"