diff configure.in @ 120:7d2108cbcd3e

Porting DW to GTK 2.0... and changed the percent value from into to a float so there won't be any rounding.
author bsmith@81767d24-ef19-dc11-ae90-00e081727c95
date Sat, 19 Oct 2002 11:46:54 +0000
parents 5e4730c42014
children d8af32b1b1cd
line wrap: on
line diff
--- a/configure.in	Sat Oct 19 06:36:41 2002 +0000
+++ b/configure.in	Sat Oct 19 11:46:54 2002 +0000
@@ -49,8 +49,14 @@
 AC_CHECK_LIB(dgc, inet_addr, LIBS="$LIBS -ldgc",)
 AC_CHECK_LIB(resolv, gethostbyname, LIBS="$LIBS -lresolv",)
 
-AM_PATH_GLIB(1.2.0,,AC_MSG_ERROR(AC_MSG_ERROR(Cannot find GLIB: Is glib-config in path?)))
-AM_PATH_GTK(1.2.0,,AC_MSG_ERROR(AC_MSG_ERROR(Cannot find GTK: Is gtk-config in path?)), gthread)
+AC_CHECK_PROG(PKG_CFG, pkg-config, pkg-config)
+if test x"$PKG_CFG" = x; then
+  AM_PATH_GLIB(1.2.0,,AC_MSG_ERROR(AC_MSG_ERROR(Cannot find GLIB: Is glib-config in path?)))
+  AM_PATH_GTK(1.2.0,,AC_MSG_ERROR(AC_MSG_ERROR(Cannot find GTK: Is gtk-config in path?)), gthread)
+else
+  GTK_CFLAGS=`$PKG_CFG --cflags gtk+-2.0 gthread-2.0`
+  GTK_LIBS=`$PKG_CFG --libs gtk+-2.0 gthread-2.0`
+fi
 
 AC_CHECK_HEADER(pthread.h,,AC_MSG_ERROR([pthread header not found. Dynamic Windows cannot build without it.]))
 AC_CHECK_LIB(pthread, pthread_attr_init, PTHREAD_LIBS="-lpthread",