diff configure.in @ 1594:6baf177f335c

Rename compat.c/h dwcompat.c/h and configure option to --with-dwcompat. There are several other projects that include compat.c and compat.h... To avoid conflicts make sure the header and source files match the library.
author bsmith@81767d24-ef19-dc11-ae90-00e081727c95
date Thu, 23 Feb 2012 12:44:15 +0000
parents 751f127439f7
children 080b764e8982
line wrap: on
line diff
--- a/configure.in	Sat Feb 18 20:45:51 2012 +0000
+++ b/configure.in	Thu Feb 23 12:44:15 2012 +0000
@@ -41,11 +41,11 @@
 dnl Checks for system
 AC_CANONICAL_SYSTEM
 
-dnl ---------------------- check for '--with-compat' switch -----------------
-AC_ARG_WITH(compat,
-   [  --with-compat           specify this to build the optional dwcompat library],
-   [with_compat=$withval],
-   [with_compat=no],
+dnl ---------------------- check for '--with-dwcompat' switch -----------------
+AC_ARG_WITH(dwcompat,
+   [  --with-dwcompat           specify this to build the optional dwcompat library],
+   [with_dwcompat=$withval],
+   [with_dwcompat=no],
 )
 
 dnl ---------------------- check for '--with-gtk3' switch -----------------
@@ -56,9 +56,9 @@
 )
 
 dnl ---------------------- default targets to build -----------------
-if test $with_compat = yes; then
-   COMPAT_OBJECT="compat.o"
-   INSTALL_COMPAT="installcompat"
+if test $with_dwcompat = yes; then
+   COMPAT_OBJECT="dwcompat.o"
+   INSTALL_COMPAT="installdwcompat"
    SYSCONF_LINK_TARGET_SHARED2="lib$TARGET2.$SOSUFFIX.\$(DW_MAJOR_VERSION).\$(DW_MINOR_VERSION)"
 else
    COMPAT_OBJECT=""