diff configure.in @ 1913:5d32be499016

The GTK MDI code is filling up with deprecated calls and it is becoming a hassle to maintain, it still builds just with many warnings... however since MDI is considered deprecated due to lack of support on MacOS X, I am making the GTK MDI code build optional with the --with-deprecated configure switch. MDI code will still be built on Windows and OS/2... With stub code on MacOS X... GTK will require the --with-deprecated switch to build the code.
author bsmith@81767d24-ef19-dc11-ae90-00e081727c95
date Sun, 19 Jun 2016 18:08:52 +0000
parents 495793f9b503
children dee122916f3c
line wrap: on
line diff
--- a/configure.in	Sun Jun 19 17:21:20 2016 +0000
+++ b/configure.in	Sun Jun 19 18:08:52 2016 +0000
@@ -55,6 +55,13 @@
    [with_gtk3=no],
 )
 
+dnl ---------------------- check for '--with-deprecated' switch -----------------
+AC_ARG_WITH(deprecated,
+   [  --with-deprecated         specify this to build with deprecated functions],
+   [with_deprecated=$withval],
+   [with_deprecated=no],
+)
+
 dnl ---------------------- default targets to build -----------------
 if test $with_dwcompat = yes; then
    COMPAT_OBJECT="dwcompat.o"
@@ -304,6 +311,9 @@
 
 CFLAGS="$CFLAGS $GTK_CFLAGS $GDK_IMLIB_FLAGS $MOZEMBED_CFLAGS"
 
+if test $with_deprecated = yes; then
+   CFLAGS="$CFLAGS -DDW_INCLUDE_DEPRECATED"
+fi
 BROWSER_OBJECT=""
 if test x"$MOZEMBED_CFLAGS" != x; then
    SAVE_LIBS="$LIBS"