diff configure.in @ 2130:55c6587f269c

Mac: Add --with-sdk option to configure to specify an alternate MacOS SDK location.
author bsmith@81767d24-ef19-dc11-ae90-00e081727c95
date Tue, 30 Jun 2020 19:17:41 +0000
parents 2fb132a1d1fa
children 07f1366a724c
line wrap: on
line diff
--- a/configure.in	Tue Jun 30 18:26:01 2020 +0000
+++ b/configure.in	Tue Jun 30 19:17:41 2020 +0000
@@ -64,11 +64,18 @@
 
 dnl ---------------------- check for '--with-arch' switch -----------------
 AC_ARG_WITH(arch,
-   [  --with-arch             specify architecture: one of all, 32bit, 64bit, intel, ppc, ppc64, x86_64, i386],
+   [  --with-arch             specify MacOS architecture: one of all, 32bit, 64bit, intel, arm, ppc, ppc64, x86_64, i386],
    [with_arch=$withval],
    [with_arch=no],
 )
 
+dnl ---------------------- check for '--with-sdk' switch -----------------
+AC_ARG_WITH(sdk,
+   [  --with-sdk              specify this to build with an alternate MacOS SDK location],
+   [with_sdk=$withval],
+   [with_sdk=no],
+)
+
 AC_HEADER_STDC
 AC_HEADER_DIRENT
 AC_CHECK_HEADERS(unistd.h)
@@ -141,6 +148,13 @@
             ARCH="-arch $with_arch"
             ;;
       esac
+      case "$with_sdk" in
+         no)
+            ;;
+         *)
+            CC="$CC -isysroot$with_sdk"
+            ;;
+      esac
       SHAREDFLAG="-dynamiclib -flat_namespace -undefined suppress -headerpad_max_install_names"
       SOSUFFIX=dylib
       DW_DIR=mac