diff configure.in @ 2111:37ce3e22ee1a

GTK: Split installdwtest into a separate make rule and don't enable it when building for MacOS. dwtest is not usable on MacOS without the bundle and the desktop file is completely unused.
author bsmith@81767d24-ef19-dc11-ae90-00e081727c95
date Wed, 17 Jun 2020 16:50:24 +0000
parents 068681933258
children 17f5c1c199b4
line wrap: on
line diff
--- a/configure.in	Wed Jun 17 08:43:11 2020 +0000
+++ b/configure.in	Wed Jun 17 16:50:24 2020 +0000
@@ -15,7 +15,7 @@
 SOSUFFIX=so
 LIBSUFFIX=a
 LIBPREFIX=lib
-
+INSTALL_TEST="installdwtest"
 INCLUDES="-I."
 
 AC_PROG_CC
@@ -146,6 +146,7 @@
       LIBS="$LIBS -framework Cocoa -framework WebKit"
       save_libs="$LIBS"
       LIBS="$LIBS -framework UserNotifications"
+      INSTALL_TEST=""
       AC_CHECK_FUNC(exit, , [LIBS="$save_libs"])
       build_gtk="no"
    ;;
@@ -308,6 +309,7 @@
 AC_SUBST(BROWSER_OBJECT)
 AC_SUBST(COMPAT_OBJECT)
 AC_SUBST(INSTALL_COMPAT)
+AC_SUBST(INSTALL_TEST)
 
 AC_SUBST(ARCH)