diff configure.in @ 2185:2a52d9fc2de4

Mac: Added configure option --with-arch=modern that builds 64bit Intel and ARM.
author bsmith@81767d24-ef19-dc11-ae90-00e081727c95
date Wed, 14 Oct 2020 04:13:58 +0000
parents 07f1366a724c
children c677d728e143
line wrap: on
line diff
--- a/configure.in	Wed Oct 14 03:27:02 2020 +0000
+++ b/configure.in	Wed Oct 14 04:13:58 2020 +0000
@@ -64,7 +64,7 @@
 
 dnl ---------------------- check for '--with-arch' switch -----------------
 AC_ARG_WITH(arch,
-   [  --with-arch             specify MacOS architecture: one of all, 32bit, 64bit, intel, arm, ppc, ppc64, x86_64, i386],
+   [  --with-arch             specify MacOS architecture: one of modern, all, 32bit, 64bit, intel, arm, ppc, ppc64, x86_64, i386],
    [with_arch=$withval],
    [with_arch=no],
 )
@@ -144,6 +144,9 @@
          arm)
             ARCH="-arch arm64"
             ;;
+         modern)
+            ARCH="-arch x86_64 -arch arm64"
+            ;;
          *)
             ARCH="-arch $with_arch"
             ;;