diff configure.in @ 251:18ecaae9cc3b

Changed configure to make sure we find gtk 2.0, and not just pkg-config, when checking for GTK 2.x versus GTK 1.x.
author bsmith@81767d24-ef19-dc11-ae90-00e081727c95
date Wed, 19 Feb 2003 17:26:41 +0000
parents 4c4e94a63748
children a8015e02b590
line wrap: on
line diff
--- a/configure.in	Wed Feb 19 11:14:29 2003 +0000
+++ b/configure.in	Wed Feb 19 17:26:41 2003 +0000
@@ -50,7 +50,11 @@
 AC_CHECK_LIB(resolv, gethostbyname, LIBS="$LIBS -lresolv",)
 
 AC_CHECK_PROG(PKG_CFG, pkg-config, pkg-config)
-if test x"$PKG_CFG" = x; then
+if test x"$PKG_CFG" != x; then
+  GTK_LIBS=`$PKG_CFG --silence-errors --libs gtk+-2.0 gthread-2.0`
+fi
+
+if test x"$GTK_LIBS" = x; then
   AM_PATH_GLIB(1.2.0,,AC_MSG_ERROR(AC_MSG_ERROR(Cannot find GLIB: Is glib-config in path?)))
   AM_PATH_GTK(1.2.0,,AC_MSG_ERROR(AC_MSG_ERROR(Cannot find GTK: Is gtk-config in path?)), gthread)
   AM_PATH_GDK_IMLIB(1.9.4, AC_DEFINE(USE_IMLIB), AC_MSG_ERROR(IMLIB not found or too old. Dynamic Windows cannot build without it.))