comparison debian/changelog @ 1605:f0a4731bc40e

Added debian changelog for version 2.3.
author bsmith@81767d24-ef19-dc11-ae90-00e081727c95
date Sun, 26 Feb 2012 10:49:54 +0000
parents edad104e7714
children 6762e29938a2
comparison
equal deleted inserted replaced
1604:7eb2e2d6b0be 1605:f0a4731bc40e
1 dwindows (2.3-1) unstable; urgency=low
2
3 * Added dw_menu_delete_item() for removing menu items.
4 Now you can use dw_window_destroy() on menu items handles also.
5 * Added dw_app_dir() which attempts to locate private application data
6 for the current platform.
7 * Added dw_window_set_tooltip() for adding tooltips to most widgets.
8 * Added dw_window_get_preferred_size() for getting the size the system
9 thinks the widget should be, to aid in creating layouts.
10 * Added support for -1 size parameter to the dw_box_pack*() functions to
11 automatically figure out a suggested size for many controls.
12 * Added automatic window redraw support for OS/2, Windows and Mac.
13 * Added dw_window_set_gravity() for enhanced window placement.
14 * Added DW_GRAV_OBSTACLES support for using system obstacles as gravity
15 anchor points on OS/2, Mac, Windows and GTK3 (3.4 and later).
16 * Added automatic window border detection on GTK.
17 This eliminates the need for the DW_BORDER_* environment variables.
18 * Added Open Watcom compiler support for OS/2 (Thanks Andy Willis).
19 * Added pseudo transparent background widget support on Windows and OS/2.
20 If you set the background color of a widget to DW_RGB_TRANSPARENT...
21 it will attempt to use the background color of the parent.
22 Several types of widgets have this set by default now.
23 * Added faster and less buggy layout engine 2.0 for OS/2, Windows and Mac.
24 * Added auto-positioning on Mac; reimplemented auto-positioning on OS/2.
25 * Added DW_DRAW_NOAA which can be passed to dw_draw_*() API functions
26 that accept the flags parameter to disable anti-aliasing.
27 * Added dw_main_quit() to cause the dw_main() message loop to return.
28 * Added DW_FCF_COMPOSITED to enable Aero Glass effects on Windows 7 and Vista.
29 * Added local autorelease pools on Mac making _dw_pool_drain() unnecessary.
30 * Added deprecated API support for Clang, GCC and Visual C compilers.
31 dw_mdi_new() and dw_menu_item_set_check() have been deprecated.
32 * Fixed auto-sizing top-level windows on Windows; added on OS/2 and Mac.
33 * Fixed bubble help not being displayed on Windows.
34 * Fixed menu bar items remaining highlighted on Mac.
35 * Fixed OS/2 and Windows showing windows during dw_window_set_pos/size().
36 * Fixed OS/2 scrollbox resizing problems when not in the initial position.
37 * Fixed Windows scrollbox maximum position is off by one.
38 * Fixed various GTK3 issues and removed all deprecated functions for 3.4.
39 * Fixed MLE issues on almost all platforms.
40 * Removed broken support for GTK 3.0, GTK 3.2 or later is required now.
41 * Deprecated DW_FCF_NOBYTEALIGN, DW_FCF_SHELLPOSITION, DW_FCF_HORZSCROLL and
42 DW_FCF_VERTSCROLL flags.
43 * Renamed compat.c and compat.h to dwcompat.c and dwcompat.h respectively.
44
45 -- Brian Smith <brian@dbsoft.org> Sun, 26 Feb 2012 08:00:00 +1000
46
1 dwindows (2.2-1) unstable; urgency=low 47 dwindows (2.2-1) unstable; urgency=low
2 48
3 * Added printing support via dw_print_new, dw_print_run and dw_print_cancel. 49 * Added printing support via dw_print_new, dw_print_run and dw_print_cancel.
4 * Added pixmap font override support. In prior versions when drawing 50 * Added pixmap font override support. In prior versions when drawing
5 text to pixmaps the font set on the associated window handle is used. 51 text to pixmaps the font set on the associated window handle is used.