comparison debian/rules @ 643:9ab89d89e6b4

Add dw_listview_insert() Default to using webkit for Gtk+ HTML widget Add option to build with libgtkhtml2 - incomplete Initial attempt to use customdraw for Win32 container - not working Added dw_window_get_font() for Gtk+ - not implemented in other ports yet Change package name from dw to dwindows for Linux ports - use dwindows-config now Add debian package build target
author mhessling@81767d24-ef19-dc11-ae90-00e081727c95
date Sun, 03 Oct 2010 00:34:36 +0000
parents
children
comparison
equal deleted inserted replaced
642:fda03b13ebda 643:9ab89d89e6b4
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
8
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11
12
13 # These are used for cross-compiling and for saving the configure script
14 # from having to guess our platform (since we know it already)
15 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
16 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
17
18
19 config.status: configure
20 dh_testdir
21 # Add here commands to configure the package.
22 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
23 cp -f /usr/share/misc/config.sub config.sub
24 endif
25 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
26 cp -f /usr/share/misc/config.guess config.guess
27 endif
28 ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs"
29
30
31 build: build-stamp
32
33 build-stamp: config.status
34 dh_testdir
35
36 # Add here commands to compile the package.
37 $(MAKE)
38 #docbook-to-man debian/dwindows.sgml > dwindows.1
39
40 touch $@
41
42 clean:
43 dh_testdir
44 dh_testroot
45 rm -f build-stamp
46
47 # Add here commands to clean up after the build process.
48 -$(MAKE) distclean
49 rm -f config.sub config.guess
50
51 dh_clean
52
53 install: build
54 dh_testdir
55 dh_testroot
56 dh_clean -k
57 dh_installdirs
58
59 # Add here commands to install the package into debian/dwindows.
60 $(MAKE) prefix=$(CURDIR)/debian/dwindows/usr install
61
62
63 # Build architecture-independent files here.
64 binary-indep: build install
65 # We have nothing to do by default.
66
67 # Build architecture-dependent files here.
68 binary-arch: build install
69 dh_testdir
70 dh_testroot
71 dh_installchangelogs
72 dh_installdocs
73 dh_installexamples
74 # dh_install
75 # dh_installmenu
76 # dh_installdebconf
77 # dh_installlogrotate
78 # dh_installemacsen
79 # dh_installpam
80 # dh_installmime
81 # dh_python
82 # dh_installinit
83 # dh_installcron
84 # dh_installinfo
85 dh_installman
86 dh_link
87 dh_strip
88 dh_compress
89 dh_fixperms
90 # dh_perl
91 dh_makeshlibs
92 dh_installdeb
93 dh_shlibdeps
94 dh_gencontrol
95 dh_md5sums
96 dh_builddeb
97
98 binary: binary-indep binary-arch
99 .PHONY: build clean binary-indep binary-arch binary install